leaking JBL cristalprofi

toadass

Member
Joined
26 Aug 2010
Messages
185
Hi guys, I have been out of the planted tank scene for around 8 months. (Pregnant other half and a baby boy). I give my ADA 60p a full going over as nothing had been touched for months. Filled up after a good scrub and clean of everything. I now have a leak coming from my filter where the fastner clips are. This was fine until I give it a clean. Can anybody tell me what they think this could be? A seal or something???
Thanks guys
 

toadass

Member
Joined
26 Aug 2010
Messages
185
Ye thinking it might be, I have ordered a pump head gasket and see what happens. Although it wont be here fir a few days
 

tim

Member
Joined
22 Aug 2011
Messages
3,823
Location
Middlesex.
Have you checked the seal is seated properly mate, I had a twisted rubber seal on a cristalprofi causing it to leak.
 

LancsRick

Member
Joined
18 Apr 2012
Messages
684
Two things I'd check here:

1) On the Cristalprofi's, if you don't have the media baskets in perfectly level (with handles flat) then the clamps will still lock, but it won't be watertight. Try resetting all the baskets.
2) Seal as mentioned above.
 

Alastair

Member
Joined
27 Dec 2009
Messages
4,404
Location
Denton, Manchester
Two things I'd check here:

1) On the Cristalprofi's, if you don't have the media baskets in perfectly level (with handles flat) then the clamps will still lock, but it won't be watertight. Try resetting all the baskets.
2) Seal as mentioned above.
Or if its only a very light drip it could be water trapped in one of the clips from cleaning it thats dripping down the side of the filter unless its instantly back as soon as you wipe it

Sent from my GT-I9505 using Tapatalk 2
 

toadass

Member
Joined
26 Aug 2010
Messages
185
Thanks guys, touch wood it was ok this morning. But im away for the day and overnight so paranoid what I might go home to. I haven't checked the baskets, I shall order a new seal anyway, too scared to touch it this morning incase it started dripping again.
 
Top