• You are viewing the forum as a Guest, please login (you can use your Facebook, Twitter, Google or Microsoft account to login) or register using this link: Log in or Sign Up
  • You can now follow UKAPS on Instagram.

First Tank! Help needed please

Aitch

New Member
Joined
26 Jul 2021
Messages
11
Location
Essex UK
Good afternoon everyone this is my first ever tank. I went for a juwel primo 70 with eco complete as the substrate. I've used beneficial bacteria to start fishless cycle and my current readings for day 2 are

AMMONIA 0.50ppm
NITRITE 0.50ppm
NITRATE 5-10ppm
PH 7.2
HIGH RANGE PH 7.4

My question is when my levels are stable should I do a small water change, remove debris from filter and wait before adding a few fish?

Regards
Harry

PXL_20210731_151501659.jpg
 

sparkyweasel

Member
Joined
30 Jun 2011
Messages
2,086
Hi Harry. :)
Is that ammonia reading due to you adding ammonia? Some people are still advising that, but it goes against modern knowledge about 'cycling' a tank.
Have a look at this post, and particularly the ones the links in it lead to.
Cycling.
hth
 

Karmicnull

Member
Joined
6 Sep 2020
Messages
456
Location
Cambridge
See also this thread. Add a lot more plants, and then let the tank mature for a few weeks. The plants will take on much of the job of filtration, and then you're free to add your fish gradually over time, letting your tank adjust and get used to them after you've added each batch. And you're secure in the knowledge that you've got belt and braces of filter and plants both keeping your water clean.
Cheers,
Simon
 

Aitch

New Member
Thread starter
Joined
26 Jul 2021
Messages
11
Location
Essex UK
I've added some more plants but one of the first ones I put in there is not doing so well. I've posted a thread in the plants section
PXL_20210802_082823891.MP.jpg
 

Similar threads

Top