• You are viewing the forum as a Guest, please login (you can use your Facebook, Twitter, Google or Microsoft account to login) or register using this link: Log in or Sign Up
  • You can now follow UKAPS on Instagram.

Enigma - My 20 gallon madness

NotoriousENG

Member
Thread starter
Joined
17 Jul 2021
Messages
117
Location
Eastern USA
@GHNelson it certainly looks similar to what I have. However, considering that I bought this ludwigia as a bunch plant from Petco it seems unlikely that it would be such an uncommon species. I think it was labeled as Ludwigia Repens Broadleaf when I got it. I will have to check the tags next time I am at petco. I'm pretty sure it looked like L. Repens when I bought it and then evolved into its new look after it started growing in my tank.
 

NotoriousENG

Member
Thread starter
Joined
17 Jul 2021
Messages
117
Location
Eastern USA
The end of an Era...

After fighting a massive wave of green spot followed by the invasion on a seemingly un-killable staghorn and decorating plant health I did a massive rescape of the tank about a week ago. Here's the final picture of the tank with its orginal scape.

036e6f086b17e6adcae602e2517132c7.jpg


Part of the reason for the reason for the rescape was that the gorgeous stump I used a centerpiece was falling apart which I suspect was not helping the algae problem, though I'm sure monkey with co2 in an attempt for better efficiency was also a main cause. I also needed to get in there and remove as much dead and dying plant matter and algae as I could.

The new scape is all local rock (a mud stone I believe). I've also decided to just accept that this tank needs a high injection rate, bring nitrogen levels up to 25 ppm, and try to avoid excel and h2o2 (I managed to melt a lot of the plants at one point). I'm also currently using flourish comprehensive with some addironal Fe-DTPA instead of the CSM+B & Fe-DTPA I was using.


Here's how it looks one week in. It's a bit crowded as there are some crypts and lily bulbs I need to sell or give away. The left is also a mess as I am mainly working on bringing my stems back from the brink of death. However, I would appreciate any critiques or suggestions.
61a213db169e841695d981a9ef18b3f5.jpg


The final news is that I picked up a fluval 3.0 a few days ago. I had to hang it pretty high to get decent coverage and the ends still seem a little dark. Any feedback on the light settings are appreciated as I chose them somewhat arbitrarily.
8c64559667e64fd0ab5d647032d3ff60.jpg


Sent from my SM-G970U1 using Tapatalk
 
Top