• You are viewing the forum as a Guest, please login (you can use your Facebook, Twitter, Google or Microsoft account to login) or register using this link: Log in or Sign Up
  • You can now follow UKAPS on Instagram.

Diffuser making a strange noise

EA James

Member
Joined
22 Jul 2019
Messages
535
Location
Staines-upon-Thames
Hi all,
I’ve noticed a strange noise coming from my co2 art diffuser. It’s also realising a large bubble at the same time the noise starts, does it need replacing?


Hopefully this link works, never done this before!
 

Tom Michael

Member
Joined
16 Nov 2014
Messages
256
It looks to me like you have a break in the sealant, hence the large bubble and I guess the hissing sounds. I doubt it would be easy to reseal so you might want to replace.

I have the same diffuser and it’s the best I have used. I just purchased another one for a new scape and the membrane is now brown so might be more sturdy.

I have broken a few diffusers over the years - my tip only clean in bleach solution never scrub!
 

EA James

Member
Thread starter
Joined
22 Jul 2019
Messages
535
Location
Staines-upon-Thames
Cheers @Tom Michael better off just to replace it i guess, I've seen the new ones are brown which i think would look less obvious in the tank, perfect excuse!

I clean mine with thin bleach and water 50/50 mix, i let it soak for about an hour during WC and then rinse it under the tap. Is that the right way?? Also i think i read somewhere before that you're not meant to touch the ceramic part of the diffuser, is that right??

Thanks again mate :)
 

Tom Michael

Member
Joined
16 Nov 2014
Messages
256
Cheers @Tom Michael better off just to replace it i guess, I've seen the new ones are brown which i think would look less obvious in the tank, perfect excuse!

I clean mine with thin bleach and water 50/50 mix, i let it soak for about an hour during WC and then rinse it under the tap. Is that the right way?? Also i think i read somewhere before that you're not meant to touch the ceramic part of the diffuser, is that right??

Thanks again mate :)
Yes that’s all correct. I damaged the seal on two aquario diffusers by just handling too heavy- basically when pulling the co2 tube off! My guess is that there not that resilient (or it could just be me!) I also wonder why they changed to the brown material, could be a few people have had this issue perhaps!
 

Similar threads

Top