• You are viewing the forum as a Guest, please login (you can use your Facebook, Twitter, Google or Microsoft account to login) or register using this link: Log in or Sign Up
  • You can now follow UKAPS on Instagram.

Buce and Anubias problems

Jamesbaa

New Member
Joined
28 Sep 2018
Messages
24
Location
London
Hi Guys, I need some expert help. Had my nano tank running for around 9 months with the current set up. The Anubias seemed to be doing pretty well and I noticed some new growth on my buce wavy green.

Over the last week or so I've noticed the Buce has been dropping all its large leaves and the Anubias leaves seem to be going clear and very fragile.

I run Co2 injection, I daily dose Evolution Aqua all in one and also daily dose liquid Co2.

The tank is 30lt and I dose the EA at 1.5ml Pd and the Liquid Co2 at 0.5ml PD.

I think its a fertiliser issue but not sure what route to go down, I run very low light power on the fluval plant light. I'm wondering if I should change my fertilizer? Was contemplating the tropical but wasn't sure which one to go for? I like the idea of only having to dose once a week. The tank is stocked with CPD's, neon tetras and pygmy corries

Thanks
 

Attachments

  • 20201230_195107.jpg
    20201230_195107.jpg
    771.7 KB · Views: 67
  • 20201230_195131.jpg
    20201230_195131.jpg
    1.4 MB · Views: 58
  • 20201230_195142.jpg
    20201230_195142.jpg
    1 MB · Views: 59

Kezzab

Member
Joined
18 Jan 2016
Messages
1,408
Location
Carlisle
It's unlikely to be ferts issue given its been working fine for 9 months.

My guess would be something's changed with your co2. Rule that out first.

You could dose your EA ferts once a week if you wanted, but daily or several times a week means less swinging tank parameters.

I also find that both these plants sometimes just go funny for a while then recover.
 

Similar threads

Top